<!DOCTYPE html>
<!--[if lt IE 7]><html class="lt-ie9 lt-ie8 lt-ie7" lang="en" dir="ltr"><![endif]-->
<!--[if IE 7]><html class="lt-ie9 lt-ie8" lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="lt-ie9" lang="en" dir="ltr"><![endif]-->
<!--[if gt IE 8]><!--><html lang="en" dir="ltr"><!--<![endif]-->
<head>
<meta charset="utf-8" />
<meta property="og:url" content="https://www.eastcountymagazine.org/snow-day-schools-closed-east-county-mountain-communities" />
<meta property="og:site_name" content="East County Magazine" />
<link rel="shortcut icon" href="https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/favicon_0.ico" type="image/vnd.microsoft.icon" />
<meta property="og:description" content="February 22, 2022 (San Diego&#039;s East County) -- Due to an impending snowstorm, schools in the following school districts will be closed on Wednesday, Feb. 23, the County Office of Education has announc" />
<meta property="og:image" content="https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/styles/thumbnail/public/School%20%20closed%20cc%20via%20bing_0.png?itok=utJuqYZJ" />
<meta property="og:title" content="SNOW DAY:  SCHOOLS CLOSED IN EAST COUNTY MOUNTAIN COMMUNITIES" />
<link rel="canonical" href="/snow-day-schools-closed-east-county-mountain-communities" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="shortlink" href="/node/37224" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<title>SNOW DAY:  SCHOOLS CLOSED IN EAST COUNTY MOUNTAIN COMMUNITIES | East County Magazine</title>
<style type="text/css" media="all">
@import url("https://www.eastcountymagazine.org/modules/system/system.base.css?r55psq");
@import url("https://www.eastcountymagazine.org/modules/system/system.menus.css?r55psq");
@import url("https://www.eastcountymagazine.org/modules/system/system.messages.css?r55psq");
@import url("https://www.eastcountymagazine.org/modules/system/system.theme.css?r55psq");
</style>
<style type="text/css" media="all">
@import url("https://www.eastcountymagazine.org/sites/all/modules/calendar/css/calendar_multiday.css?r55psq");
@import url("https://www.eastcountymagazine.org/modules/comment/comment.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/modules/date/date_api/date.css?r55psq");
@import url("https://www.eastcountymagazine.org/modules/field/theme/field.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/modules/logintoboggan/logintoboggan.css?r55psq");
@import url("https://www.eastcountymagazine.org/modules/node/node.css?r55psq");
@import url("https://www.eastcountymagazine.org/modules/poll/poll.css?r55psq");
@import url("https://www.eastcountymagazine.org/modules/search/search.css?r55psq");
@import url("https://www.eastcountymagazine.org/modules/user/user.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/modules/views/css/views.css?r55psq");
</style>
<style type="text/css" media="all">
@import url("https://www.eastcountymagazine.org/sites/all/modules/ctools/css/ctools.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/modules/panels/css/panels.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/modules/print/print_ui/css/print_ui.theme.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/modules/addtoany/addtoany.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/libraries/superfish/css/superfish.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/libraries/superfish/css/superfish-vertical.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/libraries/superfish/style/white.css?r55psq");
</style>
<style type="text/css" media="screen">
@import url("https://www.eastcountymagazine.org/sites/all/themes/adaptivetheme/at_core/css/at.settings.style.headings.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/themes/adaptivetheme/at_core/css/at.layout.css?r55psq");
</style>
<style type="text/css" media="all">
@import url("https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/styles.base.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/styles.settings.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/styles.modules.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/color/at_magazine-cd98e1c4/colors.css?r55psq");
@import url("https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/styles.custom.css?r55psq");
</style>
<style type="text/css" media="screen">
@import url("https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/adaptivetheme/at_magazine_files/at_magazine.default.layout.css?r55psq");
</style>
<link type="text/css" rel="stylesheet" href="https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/adaptivetheme/at_magazine_files/at_magazine.responsive.layout.css?r55psq" media="only screen" />
<style type="text/css" media="screen">
@import url("https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/adaptivetheme/at_magazine_files/at_magazine.fonts.css?r55psq");
</style>
<style type="text/css" media="all">
@import url("https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/adaptivetheme/at_magazine_files/at_magazine.menutoggle.css?r55psq");
</style>
<link type="text/css" rel="stylesheet" href="https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/responsive.custom.css?r55psq" media="only screen" />
<link type="text/css" rel="stylesheet" href="https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/responsive.smalltouch.portrait.css?r55psq" media="only screen and (max-width:320px)" />
<link type="text/css" rel="stylesheet" href="https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/responsive.smalltouch.landscape.css?r55psq" media="only screen and (min-width:321px) and (max-width:580px)" />
<link type="text/css" rel="stylesheet" href="https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/responsive.tablet.portrait.css?r55psq" media="only screen and (min-width:581px) and (max-width:768px)" />
<link type="text/css" rel="stylesheet" href="https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/responsive.tablet.landscape.css?r55psq" media="only screen and (min-width:769px) and (max-width:1024px)" />
<link type="text/css" rel="stylesheet" href="https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/responsive.desktop.css?r55psq" media="only screen and (min-width:1025px)" />

<!--[if IE 6]>
<style type="text/css" media="screen">
@import url("https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/ie-6.css?r55psq");
</style>
<![endif]-->

<!--[if lte IE 7]>
<style type="text/css" media="screen">
@import url("https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/ie-lte-7.css?r55psq");
</style>
<![endif]-->

<!--[if IE 8]>
<style type="text/css" media="screen">
@import url("https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/ie-8.css?r55psq");
</style>
<![endif]-->

<!--[if lte IE 9]>
<style type="text/css" media="screen">
@import url("https://www.eastcountymagazine.org/sites/all/themes/at_magazine/css/ie-lte-9.css?r55psq");
</style>
<![endif]-->
<script type="text/javascript" src="https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/js/js_dYOGV15VEcvR5zyP3UKzyEH3a6wcYkaWkQCEZ8Wpd8c.js"></script>
<script type="text/javascript" src="https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/js/js_1R9GI_pczQQhEN8MMeajo7SXwdm0hXMSXrOh8zYueao.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.a2a_config=window.a2a_config||{};window.da2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='https://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);da2a.script_load=function(){};},script_onready:function(){da2a.script_ready=true;if(da2a.html_done)da2a.init();},init:function(){for(var i=0,el,target,targets=da2a.targets,length=targets.length;i<length;i++){el=document.getElementById('da2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;if(el){a2a.init('page',{target:el});el.id='';}da2a.done=true;}da2a.targets=[];}};(function ($){Drupal.behaviors.addToAny = {attach: function (context, settings) {if (context !== document && window.da2a) {if(da2a.script_ready)a2a.init_all();da2a.script_load();}}}})(jQuery);a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.callbacks.push({ready:da2a.script_onready});a2a_config.overlays=a2a_config.overlays||[];a2a_config.templates=a2a_config.templates||{};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/js/js_46oqgXM_M84R8IAmyazaQso4rCI2AJJFfTbPhbj_JdU.js"></script>
<script type="text/javascript" src="https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/js/js_nG9fb-IcjBmyT6Y8Rk4_CnJJVhLPTsMFaSVUD8cYQiI.js"></script>
<script type="text/javascript" src="https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/js/js_c58DeiqIyszP0v2tn4K8ev-Wt2vZiz-LEghNTBJISX0.js"></script>
<script type="text/javascript">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</script>
<!--[if lt IE 9]>
<script src="https://www.eastcountymagazine.org/sites/all/themes/adaptivetheme/at_core/scripts/html5.js?r55psq"></script>
<![endif]-->
</head>
<body class="html not-front not-logged-in two-sidebars page-node page-node- page-node-37224 node-type-page site-name-hidden atr-7.x-3.x atv-7.x-3.2 site-name-east-county-magazine section-snow-day-schools-closed-east-county-mountain-communities color-scheme-custom at-magazine bb-hs hl-l mb-ad rc-8 bs-l iat-r">
  <div id="skip-link" class="nocontent">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <div id="page" class="page ssc-uc ssw-n ssa-l sss-n btc-uc btw-n bta-l bts-n ntc-n ntw-n nta-l nts-n ctc-n ctw-n cta-l cts-n ptc-n ptw-n pta-l pts-n at-mt container">
 <!-- /menu bar top -->
<header id="header" class="clearfix" role="banner">	
<div id="logo"><a href="/"><img class="site-logo" src="https://www.eastcountymagazine.org/sites/eastcountymagazine.org/files/ECMlogo_1_0.png" alt="East County Magazine" /></a>	
<!-- clock-->	
<div style="position: relitive;  top: 5px;left: 90px;">
<em>"Award-winning nonprofit media in the public interest, serving San Diego's inland region"</em></div><div style="position: absolute; top: 135px;right:20px;">
<script language="Javascript">
<!--
/*
Today's date script
Visit java-scripts.net or 
http://wsabstract.com for this script
*/

 var dayName = new Array ("Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday")

 var monName = new Array ("January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November", "December")

 var now = new Date

 document.write("" + dayName[now.getDay()] + ", " + monName[now.getMonth()] + " "+now.getDate() +", "+ now.getFullYear() +"")

//-->
</script></div><!--end clock-->
</div></div>
  </header>      <div id="menu-bar-wrapper" class="clearfix">
      <div id="menu-bar" class="nav clearfix"><nav id="block-superfish-1" class="block block-superfish menu-wrapper menu-bar-wrapper clearfix odd first last block-count-1 block-region-menu-bar block-1 block-first">
              <h2 class="element-invisible block-title">Main menu</h2>
        
    <ul id="superfish-1" class="menu sf-menu sf-secondary-menu sf-horizontal sf-style-none sf-total-items-21 sf-parent-items-11 sf-single-items-10"><li id="menu-5237-1" class="first odd sf-item-1 sf-depth-1 sf-no-children"><a href="/" class="sf-depth-1">Home</a></li><li id="menu-5231-1" class="middle even sf-item-2 sf-depth-1 sf-no-children"><a href="/donate" class="sf-depth-1">Donate</a></li><li id="menu-5233-1" class="middle odd sf-item-3 sf-depth-1 sf-no-children"><a href="/about" title="" class="sf-depth-1">About/Contact</a></li><li id="menu-5234-1" class="middle even sf-item-4 sf-depth-1 sf-no-children"><a href="/wild-fire-alerts" title="" class="sf-depth-1">Subscribe</a></li><li id="menu-5228-1" class="middle odd sf-item-5 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/news" class="sf-depth-1 menuparent">News Center</a><ul><li id="menu-5258-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/news" class="sf-depth-2">ECM Top News</a></li><li id="menu-5256-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/news/east-county-round" class="sf-depth-2">East County Roundup</a></li><li id="menu-5257-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/news/ecm-world-news" class="sf-depth-2">ECM World Watch</a></li><li id="menu-5245-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/archives" title="" class="sf-depth-2">Archives</a></li></ul></li><li id="menu-5259-1" class="middle even sf-item-6 sf-depth-1 sf-total-children-10 sf-parent-children-1 sf-single-children-9 menuparent"><a href="/news-issues" class="sf-depth-1 menuparent">News issues</a><ul><li id="menu-5263-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/news/business-and-labor" class="sf-depth-2">Business and Labor</a></li><li id="menu-5264-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/news/crime-beat" class="sf-depth-2">CrimeBeat</a></li><li id="menu-5265-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/news/education" class="sf-depth-2">Education</a></li><li id="menu-5262-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/news/green-scene" class="sf-depth-2">Green Scene</a></li><li id="menu-5266-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/news/health" title="" class="sf-depth-2 menuparent">Health/Fitness</a><ul><li id="menu-5270-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/news/product-recalls" title="" class="sf-depth-3">Recalls and Safety</a></li><li id="menu-5793-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/covid-19-local-resources" title="Covid 19 Local Resources" class="sf-depth-3">Covid 19 Local Resources</a></li><li id="menu-5794-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/facebook-journalism-project-covid-19-reporting" title="" class="sf-depth-3">Facebook Journalism Project covid-19 reporting</a></li></ul></li><li id="menu-5267-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/news/obituaries" class="sf-depth-2">Obituaries</a></li><li id="menu-5260-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/news/politics" class="sf-depth-2">Politics</a></li><li id="menu-5268-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/news/weather" class="sf-depth-2">Weather</a></li><li id="menu-5320-1" class="middle odd sf-item-9 sf-depth-2 sf-no-children"><a href="/news/case-you-missed-news" title="" class="sf-depth-2">What’s New</a></li><li id="menu-5366-1" class="last even sf-item-10 sf-depth-2 sf-no-children"><a href="/news/case-you-missed-news" title="" class="sf-depth-2">Year in Review</a></li></ul></li><li id="menu-5241-1" class="middle odd sf-item-7 sf-depth-1 sf-total-children-7 sf-parent-children-1 sf-single-children-6 menuparent"><a href="/best-of-ec" class="sf-depth-1 menuparent">Best of East County</a><ul><li id="menu-5283-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/features/best-east-county" title="" class="sf-depth-2">Best Attractions</a></li><li id="menu-5284-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/features/best-east-county/best-photos-our-readers-and-staff" title="" class="sf-depth-2">Best Photos</a></li><li id="menu-5285-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/features/best-east-county/east-countys-best-videos" title="" class="sf-depth-2">Best Videos</a></li><li id="menu-5286-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/holidays-east-county-2015" title="" class="sf-depth-2">Holidays</a></li><li id="menu-5370-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/features/best-east-county/romance-east-county" title="" class="sf-depth-2">Romance</a></li><li id="menu-5312-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/features/weekend-getaways" title="" class="sf-depth-2"> Weekend Getaways</a></li><li id="menu-5313-1" class="last odd sf-item-7 sf-depth-2 sf-total-children-12 sf-parent-children-0 sf-single-children-12 menuparent"><a href="https://www.eastcountymagazine.org/AprilFoolsDay" title="" class="sf-depth-2 menuparent">April Fool’s </a><ul><li id="menu-5796-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/april-1-2021-special-edition" title="" class="sf-depth-3">2021</a></li><li id="menu-5790-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/april-1-2020-special-edition" title="" class="sf-depth-3">2020</a></li><li id="menu-5774-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="https://www.eastcountymagazine.org/april-1-2019-special-edition" title="2019" class="sf-depth-3">2019</a></li><li id="menu-5598-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/april-1-2018-special-edition" title="" class="sf-depth-3">2018</a></li><li id="menu-5506-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/april-1-2017-special-edition" title="" class="sf-depth-3">2017</a></li><li id="menu-5483-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/april-1-2016-special-edition" title="April fools day 2016" class="sf-depth-3">2016</a></li><li id="menu-5384-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/april-1-2015-special-edition" title="" class="sf-depth-3">2015</a></li><li id="menu-5314-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/features/best-east-county/april-1-2014-special-edition" title="" class="sf-depth-3">2014</a></li><li id="menu-5315-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/features/best-east-county/april-1-2013-special-edition" title="" class="sf-depth-3">2013</a></li><li id="menu-5316-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/taxonomy/term/14827" title="" class="sf-depth-3">2012</a></li><li id="menu-5385-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/features/best-east-county/april-fools-day-2011" title="" class="sf-depth-3">2011</a></li><li id="menu-5505-1" class="last even sf-item-12 sf-depth-3 sf-no-children"><a href="/features/best-east-county/special-edition-april-1-2010" title="" class="sf-depth-3">2010</a></li></ul></li></ul></li><li id="menu-5248-1" class="middle even sf-item-8 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/features/best-east-county/san-diego-bookshelf" class="sf-depth-1 menuparent">Bookshelf</a><ul><li id="menu-5317-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/features/best-east-county/san-diego-bookshelf" title="" class="sf-depth-2">All Bookshelf articles</a></li><li id="menu-5407-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/book-reviews" title="" class="sf-depth-2">Book Reviews</a></li><li id="menu-5318-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/features/best-east-county/san-diego-bookshelf/literary-events" title="" class="sf-depth-2">Literary events</a></li><li id="menu-5319-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/features/best-east-county/san-diego-bookshelf/other-literary-news" title="" class="sf-depth-2">Other literary news</a></li></ul></li><li id="menu-5230-1" class="middle odd sf-item-9 sf-depth-1 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/columns/citizens-action-report" class="sf-depth-1 menuparent">Citizens Action</a><ul><li id="menu-5271-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/columns/citizens-action-report" class="sf-depth-2">Citizens Action Report</a></li><li id="menu-5272-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/0809soundoff" title="" class="sf-depth-2">Contact Officials</a></li><li id="menu-5273-1" class="last odd sf-item-3 sf-depth-2 sf-no-children"><a href="/actioncenter" title="" class="sf-depth-2">Take Action Guide</a></li></ul></li><li id="menu-5232-1" class="middle even sf-item-10 sf-depth-1 sf-total-children-10 sf-parent-children-0 sf-single-children-10 menuparent"><a href="/resources" class="sf-depth-1 menuparent">Communities</a><ul><li id="menu-5274-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/communities/cities/el-cajon" class="sf-depth-2">El Cajon</a></li><li id="menu-5276-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/communities/cities/la-mesa" title="" class="sf-depth-2">La Mesa/Mt. Helix</a></li><li id="menu-5275-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/communities/cities/lemon-grove" class="sf-depth-2">Lemon Grove</a></li><li id="menu-5277-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/communities/cities/santee" title="" class="sf-depth-2">Santee/Lakeside</a></li><li id="menu-5278-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/communities/deserts" class="sf-depth-2">Desert areas</a></li><li id="menu-5279-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/communities/mountains" class="sf-depth-2">Mountains</a></li><li id="menu-5687-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/north-county-inland" title="" class="sf-depth-2">North County Inland</a></li><li id="menu-5381-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/communities/rural-communities" title="" class="sf-depth-2">Rural areas</a></li><li id="menu-5382-1" class="middle odd sf-item-9 sf-depth-2 sf-no-children"><a href="/resources" title="" class="sf-depth-2">Resources</a></li><li id="menu-5383-1" class="last even sf-item-10 sf-depth-2 sf-no-children"><a href="/communities/east-county-shopping-business-directory" title="" class="sf-depth-2">Shopping/Businesses</a></li></ul></li><li id="menu-5238-1" class="middle odd sf-item-11 sf-depth-1 sf-no-children"><a href="/meals_deals_and_steals" class="sf-depth-1">Coupons</a></li><li id="menu-5244-1" class="middle even sf-item-12 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/features/events" title="" class="sf-depth-1 menuparent">Events/Arts</a><ul><li id="menu-5294-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/columns/arts-and-music" class="sf-depth-2">Arts/Music</a></li><li id="menu-5293-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/calendar" class="sf-depth-2">Calendar</a></li><li id="menu-5322-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/features/best-east-county/festivals-month" title="" class="sf-depth-2">Festivals of the Month</a></li><li id="menu-5295-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/features/best-east-county/san-diego-bookshelf/literary-events" class="sf-depth-2">Literary Events</a></li></ul></li><li id="menu-5240-1" class="middle odd sf-item-13 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/features/food-wine" class="sf-depth-1 menuparent">Food &amp; Wine</a><ul><li id="menu-5367-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/features/food-wine" title="" class="sf-depth-2">Food &amp; Wine</a></li><li id="menu-5282-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/features/food-wine/best-happy-hours-east-county" title="" class="sf-depth-2">Best Happy Hours</a></li><li id="menu-5281-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/features/best-east-county/guide-fresh-local-foods" title="" class="sf-depth-2"> Fresh Local Foods</a></li><li id="menu-5280-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/columns/east-county-eater" class="sf-depth-2">Restaurant Reviews</a></li></ul></li><li id="menu-5250-1" class="middle even sf-item-14 sf-depth-1 sf-no-children"><a href="/news/green-scene" class="sf-depth-1">Green Scene</a></li><li id="menu-5469-1" class="middle odd sf-item-15 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/news/health" title="" class="sf-depth-1 menuparent">Health/Fitness</a><ul><li id="menu-5791-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/covid-19-local-resources" title="" class="sf-depth-2">Covid 19 Local Resources</a></li><li id="menu-5792-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="/facebook-journalism-project-covid-19-reporting" title="" class="sf-depth-2">Facebook Journalism Project covid-19 reporting</a></li></ul></li><li id="menu-5252-1" class="middle even sf-item-16 sf-depth-1 sf-no-children"><a href="/news/homes" class="sf-depth-1">Homes &amp; Gardens</a></li><li id="menu-5242-1" class="middle odd sf-item-17 sf-depth-1 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/people" class="sf-depth-1 menuparent">People/Views</a><ul><li id="menu-5288-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/columns" class="sf-depth-2">Columns</a></li><li id="menu-5287-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/editorials" class="sf-depth-2">Editorials</a></li><li id="menu-5289-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/features/latino-voices" class="sf-depth-2">Latino Voices</a></li><li id="menu-5403-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/features/people-power" title="" class="sf-depth-2">People Power</a></li><li id="menu-5290-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/features/refugee-voices" class="sf-depth-2">Refugee Voices</a></li><li id="menu-5291-1" class="last even sf-item-6 sf-depth-2 sf-no-children"><a href="/tribal-beat" class="sf-depth-2">Tribal Beat</a></li></ul></li><li id="menu-5310-1" class="middle even sf-item-18 sf-depth-1 sf-no-children"><a href="/news/politics" title="" class="sf-depth-1">Politics</a></li><li id="menu-5311-1" class="middle odd sf-item-19 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/east-county-magazine-live-radio-show" title="" class="sf-depth-1 menuparent">Radio</a><ul><li id="menu-5492-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/east-county-magazine-live-radio-show" title="About our Radio Show" class="sf-depth-2">About our Radio Show</a></li><li id="menu-5493-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="/east-county-magazine-live-radio-show/listen-podcasts" title="" class="sf-depth-2"> Listen to Podcasts</a></li></ul></li><li id="menu-5261-1" class="middle even sf-item-20 sf-depth-1 sf-no-children"><a href="/news/sports" title="San Diego and East County Sports" class="sf-depth-1">Sports</a></li><li id="menu-5251-1" class="last odd sf-item-21 sf-depth-1 sf-no-children"><a href="/news/wildfire-news" class="sf-depth-1">Wildfires &amp; Emergencies</a></li></ul>
</nav>
</div> <!-- /menu bar -->
    </div>
     <!-- Breadcrumbs -->
   <!-- /message -->
   <!-- /help -->

   <!-- /secondary-content -->

  
  <div id="columns" class="at-mag-columns"><div class="columns-inner clearfix">
    <div id="content-column"><div class="content-inner">

       <!-- /highlight -->

      
      <section id="main-content">

                  <header class="clearfix">
                                      <h1 id="page-title">SNOW DAY:  SCHOOLS CLOSED IN EAST COUNTY MOUNTAIN COMMUNITIES</h1>
                        
                      </header>
        
        <article id="article-37224" class="node node-page node-promoted article odd node-full clearfix" role="article">

  
        </header>
    
  
  <div class="node-content">
  <span class="print-link"><span class="print_html"><a href="https://www.eastcountymagazine.org/print/37224" title="Display a printer-friendly version of this page." class="print-page" target="_blank" rel="nofollow"><img class="print-icon print-icon-margin image-style-none" src="https://www.eastcountymagazine.org/sites/all/modules/print/icons/print_icon.png" width="16px" height="16px" alt="Printer-friendly version" title="Printer-friendly version" />Printer-friendly version</a></span></span><span class="a2a_kit a2a_kit_size_32 a2a_target addtoany_list" id="da2a_2">
      
      <a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share#url=https%3A%2F%2Fwww.eastcountymagazine.org%2Fsnow-day-schools-closed-east-county-mountain-communities&amp;title=SNOW%20DAY%3A%20%20SCHOOLS%20CLOSED%20IN%20EAST%20COUNTY%20MOUNTAIN%20COMMUNITIES"><img src="/sites/all/modules/addtoany/images/share_save_171_16.png" width="171" height="16" alt="Share this"/></a>
      
    </span>
    <div class="field field-name-taxonomy-vocabulary-4 field-type-taxonomy-term-reference field-label-hidden view-mode-full"><ul class="field-items"><li class="field-item even"><a href="/february-2022-articles">February 2022 Articles</a></li></ul></div><div class="field field-name-taxonomy-vocabulary-5 field-type-taxonomy-term-reference field-label-hidden view-mode-full"><ul class="field-items"><li class="field-item even"><a href="/taxonomy/term/2784">Mountain Empire</a></li><li class="field-item odd"><a href="/taxonomy/term/97">Julian</a></li><li class="field-item even"><a href="/spencer-valley">Spencer Valley</a></li></ul></div><div class="field field-name-body field-type-text-with-summary field-label-hidden view-mode-full"><div class="field-items"><div class="field-item even"><p style="box-sizing: border-box; margin: 0px 0px 20px; color: rgb(59, 60, 61); font-family: Montserrat, sans-serif; font-size: 15px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255); text-decoration-thickness: initial; text-decoration-style: initial; text-decoration-color: initial;"><span style="color:#000000;"><span style="font-size:16px;">February 22, 2022 (San Diego's East County) -- <img alt="" src="/sites/eastcountymagazine.org/files/2021/February/School%20%20closed%20cc%20via%20bing.png?242" style="width: 217px; height: 220px; margin: 6px; float: left;" width="217" height="220" />Due to an impending snowstorm, schools in the following school districts will be closed on Wednesday, Feb. 23, the County Office of Education has announced: </span></span></p>
<ul style="box-sizing: border-box; margin-top: 0px; padding-left: 20px; overflow: hidden; color: rgb(59, 60, 61); font-family: Montserrat, sans-serif; font-size: 15px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255); text-decoration-thickness: initial; text-decoration-style: initial; text-decoration-color: initial;">
<li style="box-sizing: border-box;"><span style="color:#000000;"><span style="font-size:16px;">Julian Union Elementary School District</span></span></li>
<li style="box-sizing: border-box;"><span style="color:#000000;"><span style="font-size:16px;">Julian Union High School District</span></span></li>
<li style="box-sizing: border-box;"><span style="color:#000000;"><span style="font-size:16px;">Mountain Empire Unified School District</span></span></li>
<li style="box-sizing: border-box;"><span style="color:#000000;"><span style="font-size:16px;">Spencer Valley School District</span></span></li>
</ul>
<p style="box-sizing: border-box; margin: 0px 0px 20px; color: rgb(59, 60, 61); font-family: Montserrat, sans-serif; font-size: 15px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255); text-decoration-thickness: initial; text-decoration-style: initial; text-decoration-color: initial;"><span style="color:#000000;"><span style="font-size:16px;">Schools in the Julian Union Elementary and Julian Union High school districts will have a late start on Thursday, Feb. 24.</span></span></p>
<!--break--><p></p>
<p style="box-sizing: border-box; margin: 0px 0px 20px; color: rgb(59, 60, 61); font-family: Montserrat, sans-serif; font-size: 15px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255); text-decoration-thickness: initial; text-decoration-style: initial; text-decoration-color: initial;"><span style="color:#000000;"><span style="font-size:16px;">Due to high winds – which make travel to and from school challenging, especially for high-profile vehicles such as school buses – schools in the Mountain Empire Unified School District were closed on Tuesday, Feb. 22. Additionally, the Julian Union Elementary, Julian Union High, and Spencer Valley school districts declared a snow day and were closed on Feb. 22.</span></span></p>
<p style="box-sizing: border-box; margin: 0px; color: rgb(59, 60, 61); font-family: Montserrat, sans-serif; font-size: 15px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255); text-decoration-thickness: initial; text-decoration-style: initial; text-decoration-color: initial;"><span style="font-size:16px;"><span style="color:#000000;"> Follow </span><a aria-describedby="audioeye_new_window_message" href="https://twitter.com/sandiegocoe" style="box-sizing: border-box; background-color: transparent; text-decoration: underline; font-weight: 700; color: rgb(0, 65, 148); transition: background 0.3s ease 0s, color 0.3s ease 0s;" target="_blank">@SanDiegoCOE</a> <span style="color:#000000;">on Twitter for real-time updates.</span></span></p>
</div></div></div>  </div>

<br />
<div id="messages"><div class="messages warning"><h2 class="element-invisible">Error message</h2>Support community news in the public interest! As nonprofit news, we rely on donations from the public to fund our reporting -- not special interests. Please donate to sustain East County Magazine's local reporting and/or wildfire alerts at <A HREF="https://www.EastCountyMedia.org/donate">https://www.eastcountymedia.org/donate</A> to help us keep people safe and informed across our region.</div></div> <!-- /message -->
<br />

      <nav class="clearfix"><ul class="links inline"><li class="addtoany first"><span><span class="a2a_kit a2a_kit_size_32 a2a_target addtoany_list" id="da2a_1">
      
      <a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share#url=https%3A%2F%2Fwww.eastcountymagazine.org%2Fsnow-day-schools-closed-east-county-mountain-communities&amp;title=SNOW%20DAY%3A%20%20SCHOOLS%20CLOSED%20IN%20EAST%20COUNTY%20MOUNTAIN%20COMMUNITIES"><img src="/sites/all/modules/addtoany/images/share_save_171_16.png" width="171" height="16" alt="Share this"/></a>
      
    </span>
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
if(window.da2a)da2a.script_load();
//--><!]]>
</script></span></li><li class="comment_forbidden last"><span><a href="/user/login?destination=node/37224%23comment-form">Log in</a> or <a href="/user/register?destination=node/37224%23comment-form">register</a> to post comments</span></li></ul></nav>
  


  


</article>
 <!-- /content -->

      </section> <!-- /main-content -->

       <!-- /content-aside -->

    </div></div> <!-- /content-column -->

    <div class="region region-sidebar-first sidebar"><div class="region-inner clearfix"><div id="block-search-form" class="block block-search no-title odd first block-count-3 block-region-sidebar-first block-form block-first" role="search">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <form action="/snow-day-schools-closed-east-county-mountain-communities" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="search" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-jUEFHELV9AFt6qufTxQab2_pI-6_rob2qka-bQXcogE" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>      </div>
    </div>
  </div>
</div>
<div id="block-block-460" class="block block-block no-title even block-count-4 block-region-sidebar-first block-460">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="https://www.eastcountymagazine.org/local-covid-19-resources-center"><img alt="" src="/sites/eastcountymagazine.org/files/2020/blocks/CovidResources-GHDNewAdClick.png" style="width: 200px; height: 170px;" width="200" height="170" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-17" class="block block-block no-title odd block-count-5 block-region-sidebar-first block-17">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="https://www.eastcountymagazine.org/donate"><img alt="" src="/images/donatebutton.jpg" style="width: 150px; height: 50px;" width="150" height="50" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-382" class="block block-block no-title even block-count-6 block-region-sidebar-first block-382">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="http://woofnrose.com" target="_blank"><img alt="" src="/sites/eastcountymagazine.org/files/resize/2016/blocks/WoofNRoseAd-200x305.png?336" style="width: 200px; height: 305px;" width="200" height="305" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-181" class="block block-block no-title odd block-count-7 block-region-sidebar-first block-181">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="http://www.sanpasqualwinery.com/" target="_blank"><img alt="" src="/sites/eastcountymagazine.org/files/images/blockads/ECVertical_Ad.jpg" width="200" height="291" border="0" /></a></p>
      </div>
    </div>
  </div>
</div>
<section id="block-comment-recent" class="block block-comment even block-count-8 block-region-sidebar-first block-recent" role="navigation">
  <div class="block-inner clearfix">
              <h2 class="block-title">Recent comments</h2>
            <div class="block-content content">
      <div class="block-content-inner clearfix">
        <div class="item-list"><ul><li class="even first"><a href="/comment/48994#comment-48994">My Perspective</a>&nbsp;<span>4 days 10 hours ago</span></li><li class="odd"><a href="/comment/48993#comment-48993">No. here&#039;s why the story was updated.</a>&nbsp;<span>4 days 12 hours ago</span></li><li class="even"><a href="/comment/48992#comment-48992">Why is the article rewritten?</a>&nbsp;<span>5 days 2 hours ago</span></li><li class="odd"><a href="/comment/48991#comment-48991">How does this benefit him?</a>&nbsp;<span>5 days 2 hours ago</span></li><li class="even"><a href="/comment/48990#comment-48990">another case</a>&nbsp;<span>5 days 7 hours ago</span></li><li class="odd"><a href="/comment/48989#comment-48989">Joel Anderson</a>&nbsp;<span>5 days 7 hours ago</span></li><li class="even"><a href="/comment/48988#comment-48988">River park link is fixed.</a>&nbsp;<span>6 days 13 hours ago</span></li><li class="odd"><a href="/comment/48987#comment-48987">wait what</a>&nbsp;<span>1 week 3 hours ago</span></li><li class="even"><a href="/comment/48986#comment-48986">correct link</a>&nbsp;<span>1 week 3 hours ago</span></li><li class="odd last"><a href="/comment/48985#comment-48985">link</a>&nbsp;<span>1 week 3 hours ago</span></li></ul></div>      </div>
    </div>
  </div>
</section>
<section id="block-user-login" class="block block-user odd block-count-9 block-region-sidebar-first block-login" role="form">
  <div class="block-inner clearfix">
              <h2 class="block-title">User login</h2>
            <div class="block-content content">
      <div class="block-content-inner clearfix">
        <form action="/snow-day-schools-closed-east-county-mountain-communities?destination=node/37224" method="post" id="user-login-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Username or e-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="15" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-password form-item-pass">
  <label for="edit-pass">Password <span class="form-required" title="This field is required.">*</span></label>
 <input type="password" id="edit-pass" name="pass" size="15" maxlength="128" class="form-text required" />
</div>
<div class="item-list"><ul><li class="even first"><a href="/user/register" title="Create a new user account.">Create new account</a></li><li class="odd last"><a href="/user/password" title="Request new password via e-mail.">Request new password</a></li></ul></div><input type="hidden" name="form_build_id" value="form-kldd72eUW7UtTwoxki9c-S8UrB-Xl5Wd4QbyCA2pSwA" />
<input type="hidden" name="form_id" value="user_login_block" />
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="Log in" class="form-submit" /></div></div></form>      </div>
    </div>
  </div>
</section>
<div id="block-block-112" class="block block-block no-title even block-count-10 block-region-sidebar-first block-112">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="/features/best-east-county/weddings-east-county"><img alt="Weddings in East County" src="/sites/eastcountymagazine.org/files/sm-weddings-button.png" width="200" height="164" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-304" class="block block-block no-title odd block-count-11 block-region-sidebar-first block-304">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="http://eastcountymagazine.org/features/food-wine/best-happy-hours-east-county"><img alt="" src="/sites/eastcountymagazine.org/files/2017/Blocks/Radiologo1-croppedtight_0.png?279" style="width: 200px; height: 71px;" width="200" height="71" /></a></p>
      </div>
    </div>
  </div>
</div>
<nav id="block-menu-menu-communitylinks" class="block block-menu even last block-count-12 block-region-sidebar-first block-menu-communitylinks" role="navigation">
  <div class="block-inner clearfix">
    
          <h2 class="block-title">Community Links</h2>
    
    <div class="block-content content">
      <div class="block-content-inner clearfix">
        <ul class="menu clearfix"><li class="first leaf menu-depth-1 menu-item-230"><a href="/business" title="">Business Associations</a></li><li class="leaf menu-depth-1 menu-item-247"><a href="/community_organizations" title="Community Organizations">Community Organizations</a></li><li class="leaf menu-depth-1 menu-item-237"><a href="/government" title="County and City Governments">County and City Governments</a></li><li class="leaf menu-depth-1 menu-item-226"><a href="http://www.eastcountysports.com" title="">East County Sports</a></li><li class="leaf menu-depth-1 menu-item-223"><a href="/immigration" title="">Immigration and Citizenship</a></li><li class="leaf menu-depth-1 menu-item-229"><a href="/media" title="">Media Resources</a></li><li class="leaf menu-depth-1 menu-item-236"><a href="/neighborhoods" title="Neighborhoods">Neighborhoods</a></li><li class="leaf menu-depth-1 menu-item-245"><a href="/parks" title="Parks and Environmental Resources">Parks and Environmental Resources</a></li><li class="leaf menu-depth-1 menu-item-224"><a href="/police" title="">Police and Sheriff Contacts</a></li><li class="leaf menu-depth-1 menu-item-220"><a href="/seniors" title="">Senior Services</a></li><li class="leaf menu-depth-1 menu-item-231"><a href="/traffic" title="">Traffic Links</a></li><li class="leaf menu-depth-1 menu-item-222"><a href="/utilities" title="">Utilities</a></li><li class="leaf menu-depth-1 menu-item-221"><a href="/veterans" title="">Veterans &amp; Military</a></li><li class="leaf menu-depth-1 menu-item-253"><a href="/visitors" title="Visitors &amp; Tourism">Visitors &amp; Tourism</a></li><li class="leaf menu-depth-1 menu-item-299"><a href="/webcams" title="WEBCAMS IN EAST COUNTY &amp; SAN DIEGO&#039;S EASTERN REGION">Webcams in East County &amp; San Diego&#039;s Eastern Region</a></li><li class="leaf menu-depth-1 menu-item-228"><a href="/wildfire" title="">Wildfire Information</a></li><li class="last leaf menu-depth-1 menu-item-227"><a href="/youth" title="">Youth Resources</a></li></ul>      </div>
    </div>

      </div>
</nav>
</div></div>    <div class="region region-sidebar-second sidebar"><div class="region-inner clearfix"><div id="block-block-464" class="block block-block no-title odd first block-count-13 block-region-sidebar-second block-464 block-first">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="/facebook-journalism-project-covid-19-reporting"><img alt="" src="/sites/eastcountymagazine.org/files/resize/2020/blocks/FJPGrantLogoForSection-200x74.png?685" style="width: 200px; height: 74px;" width="200" height="74" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-274" class="block block-block no-title even block-count-14 block-region-sidebar-second block-274">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="https://www.facebook.com/pages/East-County-Magazine/524328380924611" title="https://www.facebook.com/pages/East-County-Magazine/524328380924611"><img alt="" src="/sites/eastcountymagazine.org/files/2020/blocks/FacebookJoinUs.png?184" style="margin: 6px; width: 200px; height: 53px; float: left;" width="200" height="53" /></a></p>
      </div>
    </div>
  </div>
</div>
<nav id="block-superfish-3" class="block block-superfish odd block-count-15 block-region-sidebar-second block-3">
  <div class="block-inner clearfix">
    
          <h2 class="block-title">East County Magazine</h2>
    
    <div class="block-content content clearfix">
      <div class="block-content-inner clearfix">
        <ul id="superfish-3" class="menu sf-menu sf-menu-topright sf-vertical sf-style-white sf-total-items-5 sf-parent-items-0 sf-single-items-5"><li id="menu-5462-3" class="first odd sf-item-1 sf-depth-1 sf-no-children"><a href="http://www.calendarwiz.com/calendars/calendar.php?crd=eastcountymagazine" title="View our calendar" class="sf-depth-1">View our calendar</a></li><li id="menu-5466-3" class="middle even sf-item-2 sf-depth-1 sf-no-children"><a href="/wild-fire-alerts" title="Sign up for Wildfire Alerts and Free News Letter" class="sf-depth-1">Sign up for free newsletter</a></li><li id="menu-5463-3" class="middle odd sf-item-3 sf-depth-1 sf-no-children"><a href="/wild-fire-alerts" title="Sign up for Wildfire Alerts and Free News Letter" class="sf-depth-1">Sign up for wildfire alerts</a></li><li id="menu-5464-3" class="middle even sf-item-4 sf-depth-1 sf-no-children"><a href="/east-county-magazine-live-radio-show" title="Listen to our radio show" class="sf-depth-1">Listen to our radio show</a></li><li id="menu-5465-3" class="last odd sf-item-5 sf-depth-1 sf-no-children"><a href="/rss.xml" title="Subscribe to our RSS feed" class="sf-depth-1">Subscribe to our RSS feed</a></li></ul>      </div>
    </div>

      </div>
</nav>
<div id="block-block-458" class="block block-block no-title even block-count-16 block-region-sidebar-second block-458">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="/these-restaurants-east-county-are-offering-take-out-andor-delivery"><img alt="" src="/sites/eastcountymagazine.org/files/2021/block/RestaurantGuideSmall.png" style="width: 198px; height: 161px;" width="198" height="161" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-459" class="block block-block no-title odd block-count-17 block-region-sidebar-second block-459">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="/our-guide-local-farms-and-farm-fresh-products-sold-directly-consumers"><img alt="" src="/sites/eastcountymagazine.org/files/2021/block/FarmGuideSmall.png?809" style="width: 197px; height: 118px;" width="197" height="118" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-23" class="block block-block no-title even block-count-18 block-region-sidebar-second block-23">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="/meals_deals_and_steals"><img alt="Hot Coupons" src="/sites/eastcountymagazine.org/files/resize/2018/blocks/coupons2018-200x257.png?227" style="width: 200px; height: 257px; float: left;" width="200" height="257" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-280" class="block block-block no-title odd block-count-19 block-region-sidebar-second block-280">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="/wildfire-disaster-tips"><img alt="" src="/sites/eastcountymagazine.org/files/2013/blocks/emergencybox.png" style="width: 200px; height: 131px;" width="200" height="131" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-429" class="block block-block no-title even block-count-20 block-region-sidebar-second block-429">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="/support-ecm-while-shopping-amazon"><img alt="Support ECM while Shopping on Amazon" src="/sites/eastcountymagazine.org/files/2019/blocks/amazon-logo.jpg" style="width: 200px;" width="200" height="133" /></a></p>
      </div>
    </div>
  </div>
</div>
<div id="block-block-363" class="block block-block no-title odd last block-count-21 block-region-sidebar-second block-363">
  <div class="block-inner clearfix">
                <div class="block-content content no-title">
      <div class="block-content-inner clearfix">
        <p><a href="/sites/eastcountymagazine.org/files/2016/blocks/YouthBuildAd.png"><img alt="" src="/sites/eastcountymagazine.org/files/2016/blocks/YouthBuildAd200.png" style="width: 200px; height: 259px;" width="200" height="259" /></a></p>
      </div>
    </div>
  </div>
</div>
</div></div>
  </div></div> <!-- /columns -->

   <!-- /tertiary-content -->

  
  
  

  
</div> <!-- /page -->
  <script type="text/javascript">
<!--//--><![CDATA[//><!--
da2a.targets=[
{title:"SNOW DAY:  SCHOOLS CLOSED IN EAST COUNTY MOUNTAIN COMMUNITIES",url:"https:\/\/www.eastcountymagazine.org\/snow-day-schools-closed-east-county-mountain-communities"},
{title:"SNOW DAY:  SCHOOLS CLOSED IN EAST COUNTY MOUNTAIN COMMUNITIES",url:"https:\/\/www.eastcountymagazine.org\/snow-day-schools-closed-east-county-mountain-communities"}];
da2a.html_done=true;if(da2a.script_ready&&!da2a.done)da2a.init();da2a.script_load();
//--><!]]>
</script>
</body>
</html>
